Updated
Maintenance has completed. Thanks for your patience.
Posted
1 Aug at 12:44pm EDT.
Completed
Maintenance ended
Posted
1 Aug at 12:44pm EDT.
Updated
Database maintenance is taking a bit longer than anticipated. Should be resolved within 30 minutes. Thank you for your patience.
Posted
1 Aug at 12:32pm EDT.
Started
Database is going through standard maintenance.
Posted
1 Aug at 11:30am EDT.
Resolved